Xojo Conferences
MBSSep2018MunichDE
XDCMay2019MiamiUSA

ASCII Abfrage geht nicht mit Umlauten Nr.2 (Real Studio network user group Deutschland Mailinglist archive)

Back to the thread list
Previous thread: Eigene Klassen
Next thread: ASCII Abfrage geht nicht mit Umlauten


AW: RB Programme unter Jaguar   -   gerhard queisser
  ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Stefan Sicurella
   Re: ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Derek Meister
    Re: ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Christian Schmitz
     Re: ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Derek Meister
      Re: ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Christian Schmitz
       Re: ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Derek Meister
        Re: ASCII Abfrage geht nicht mit Umlauten Nr.2   -   Christian Schmitz

ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 06.08.02 21:26 (Tue, 6 Aug 2002 22:26:18 +0200)
From: Stefan Sicurella
Hallo,

also alle Funktionen scheinen keinen Unterschied zwischen kleinen und
grossen Umlauten zu machen, das gibt es doch nicht !

Gruß

Stefan

- - - - - - - - - -
For list commands, send "Help" in the body of a message to
<<email address removed>>

Re: ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 06.08.02 22:33 (Tue, 6 Aug 2002 23:33:15 +0200)
From: Derek Meister
>Hallo,
>
>also alle Funktionen scheinen keinen Unterschied zwischen kleinen
>und grossen Umlauten zu machen, das gibt es doch nicht !

So was sollte man sich merken....

Bzw. auf die Site mit "Kurioses" schmeissen... wie Umlaute etc. in
Menu-Namen ;-)

Hat jemand mal so ne "Bug-List" / Known Probs aufgesetzt?
Würd mich schon interessieren, da es genau DIESE Bugs sind, die einen
Wochen zurückwerfen und den letzten Nerv kosten, wenn man sie nicht
kennt...

Gruss, Derek
--

Re: ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 06.08.02 22:45 (Tue, 6 Aug 2002 23:45:27 +0200)
From: Christian Schmitz
> >Hallo,
> >
> >also alle Funktionen scheinen keinen Unterschied zwischen kleinen
> >und grossen Umlauten zu machen, das gibt es doch nicht !
>
> So was sollte man sich merken....
> Hat jemand mal so ne "Bug-List" / Known Probs aufgesetzt?

Leute, daß sind keine Bugs.

Per definition ist a=b, wenn lowercase(a)=lowercase(b).
Mid, Left, Right, etc. haben damit nix zu tun.

Mfg
Christian

-

Re: ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 07.08.02 00:02 (Wed, 7 Aug 2002 01:02:43 +0200)
From: Derek Meister
>Per definition ist a=b, wenn lowercase(a)=lowercase(b).
>Mid, Left, Right, etc. haben damit nix zu tun.

Seh ich auch so... aber, wenn:
>dim a as string
>a="Über"
>
>if mid(a,1,1)="ü" then
>beep
>end if

und es beep... Also dann ist doch was faul an dem "If"-Argument? Oder
bin ich C-Verwöhnt wo 'ü' =! 'Ü' ??

Gruss, Derek

PS: Hab das Prob nicht, aber denke mal, der gute Stefan macht hier
keinen flachs...

--

-

Re: ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 07.08.02 00:08 (Wed, 7 Aug 2002 01:08:16 +0200)
From: Christian Schmitz
> und es beep... Also dann ist doch was faul an dem "If"-Argument? Oder
> bin ich C-Verwöhnt wo 'ü' =! 'Ü' ??

Du bist verwöhnt.

Mfg
Christian

--

Re: ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 07.08.02 00:14 (Wed, 7 Aug 2002 01:14:38 +0200)
From: Derek Meister
> > bin ich C-Verwöhnt wo 'ü' =! 'Ü' ??
>
>Du bist verwöhnt.

Sacht Muttern auch immer... Aber Wert von ü ist never 'Ü' ! ;-) Das
ist ja noch nicht mal ne "Unschärferelations", das wäre dann ne
"Irgendwie-Relation". Lach. "a" ist ja auch nicht "A"! ;-???? Oder?

Gruss, Derek
--

----

Re: ASCII Abfrage geht nicht mit Umlauten Nr.2
Date: 07.08.02 21:19 (Wed, 7 Aug 2002 22:19:18 +0200)
From: Christian Schmitz
> > > bin ich C-Verwöhnt wo 'ü' =! 'Ü' ??
> >
> >Du bist verwöhnt.
>
> Sacht Muttern auch immer... Aber Wert von ü ist never 'Ü' ! ;-) Das
> ist ja noch nicht mal ne "Unschärferelations", das wäre dann ne
> "Irgendwie-Relation". Lach. "a" ist ja auch nicht "A"! ;-???? Oder?

Doch.

Aber asc("a")=asc("A") gibt false.

Mfg
Christian

--
A th