Xojo Conferences
MBSOct2019CologneDE

IDE Shortcut Keys Not Working (Real Studio network user group Mailinglist archive)

Back to the thread list
Previous thread: SMTP with attachments ?
Next thread: Re: Serial Stuff (Solved)


FFT on an audio track   -   Wright, Tim
  IDE Shortcut Keys Not Working   -   Ron Zutz
   Re: IDE Shortcut Keys Not Working   -   Joseph J. Strout
    Re: IDE Shortcut Keys Not Working   -   Ron Zutz
     Re: IDE Shortcut Keys Not Working   -   Joseph J. Strout
    Re: IDE Shortcut Keys Not Working   -   Kevin Ballard

IDE Shortcut Keys Not Working
Date: 28.08.02 14:55 (Wed, 28 Aug 2002 09:55:21 -0400)
From: Ron Zutz
Hi --

Why is RB my only Mac app without Command-H shortcut to hide the app? Not to
mention placing the shortcut on the Hide menu item in apps created with RB.
Is there a preference or something that needs to be set?

Also, when multiple edit windows are open in the IDE, the Window menu
assigns a shortcut combination (like Command-2) as the windows are open.
Sometimes they work, usually they don't work. It would be much easier to
switch edit windows via keyboard, without going to the menu, or resizing and
positioning windows so they are always clickable. Again, is there something
I should be doing differently?

Thanks.

Ron
ron at zutz dot com



---
Subscribe to the digest:
<mailto:<email address removed>>
Unsubscribe:
<mailto:<email address removed>>

Re: IDE Shortcut Keys Not Working
Date: 28.08.02 15:21 (Wed, 28 Aug 2002 07:21:12 -0700)
From: Joseph J. Strout
At 9:55 AM -0400 8/28/02, Ron Zutz wrote:

>Why is RB my only Mac app without Command-H shortcut to hide the app?

I can't imagine -- Command-H hides RB for me just fine. What version
of RB are you referring to?

>Also, when multiple edit windows are open in the IDE, the Window menu
>assigns a shortcut combination (like Command-2) as the windows are open.
>Sometimes they work, usually they don't work.

Can you define a procedure which demonstrates them not working? If
so, please report it with REALbugs.

Thanks,
- Joe

Re: IDE Shortcut Keys Not Working
Date: 28.08.02 15:37 (Wed, 28 Aug 2002 10:37:11 -0400)
From: Ron Zutz
Joe --

>> Why is RB my only Mac app without Command-H shortcut to hide the app?
>
> I can't imagine -- Command-H hides RB for me just fine. What version
> of RB are you referring to?

RB 4.5. The Command-H shortcut is available when RB first loads. Once the
project is run within the IDE, the shortcut disappears from the IDE menu and
no longer functions. It is never available on the Hide AppName menu item in
the project I'm creating.

>> Also, when multiple edit windows are open in the IDE, the Window menu
>> assigns a shortcut combination (like Command-2) as the windows are open.
>> Sometimes they work, usually they don't work.
>
> Can you define a procedure which demonstrates them not working? If
> so, please report it with REALbugs.

I'll open 2 or 3 code/window editors, the window-switching shortcuts work
fine, then for no reason that I can observe, they stop working. Sometimes
closing all editor windows and re-opening them re-enables the shortcuts, but
eventually they stop working again.

I assumed that I misunderstood how they were supposed to work. I'll try to
pay closer attention to identify any specific actions that may precede this.

Ron
ron at zutz dot com



---
Subscribe to the digest:
<mailto:<email address removed>>
Unsubscribe:
<mailto:<email address removed>>

Re: IDE Shortcut Keys Not Working
Date: 28.08.02 16:03 (Wed, 28 Aug 2002 08:03:00 -0700)
From: Joseph J. Strout
At 10:37 AM -0400 8/28/02, Ron Zutz wrote:

> > I can't imagine -- Command-H hides RB for me just fine. What version
>> of RB are you referring to?
>
>RB 4.5. The Command-H shortcut is available when RB first loads. Once the
>project is run within the IDE, the shortcut disappears from the IDE menu and
>no longer functions. It is never available on the Hide AppName menu item in
>the project I'm creating.

Ah, I see. Please report these with REALbugs and we'll see what we can do.

Thanks,
- Joe

Re: IDE Shortcut Keys Not Working
Date: 28.08.02 18:51 (Wed, 28 Aug 2002 13:51:34 -0400)
From: Kevin Ballard
They've never worked for me in OS X. I believe I REALbugged it once. Ah
yes, REALbug 68835.

On Wednesday, August 28, 2002, at 10:21 AM, Joseph J. Strout wrote:

>> Also, when multiple edit windows are open in the IDE, the Window menu
>> assigns a shortcut combination (like Command-2) as the windows are
>> open.
>> Sometimes they work, usually they don't work.
>
> Can you define a procedure which demonstrates them not working? If
> so, please report it with REALbugs.