Xojo Conferences
XDCMay2019MiamiUSA

Menu Handler firing twice in Classic (Real Studio network user group Mailinglist archive)

Back to the thread list
Previous thread: Best Way to save Xplatform File pathes?
Next thread: Extrodinarily odd: while/wend statement in regards to incrementing


Re: Your general text to file problem form a tired user!   -   Jan Erik Moström <
  Menu Handler firing twice in Classic   -   Fitzbew aol.com
   Re: Menu Handler firing twice in Classic   -   Jeff O'Brien
    Re: Menu Handler firing twice in Classic   -   Terry Ford
    Re: Menu Handler firing twice in Classic   -   Fitzbew aol.com
     Re: Menu Handler firing twice in Classic   -   Terry Ford

Menu Handler firing twice in Classic
Date: 14.08.03 20:37 (Thu, 14 Aug 2003 19:37:34 EDT)
From: Fitzbew aol.com
I've just noticed that my custom menu-handlers fire twice in RB 5.2.1 in OS
9.X, both in compiled apps and in the debugger. No problem with the same code
in RB 4.5.3, or in OS X or Win32.

Autoenable is off.

Can't find any evidence this is a known bug. Closest match I can find in the
feedback database is jxmmjrul.

Easy to reproduce in a new empty project.

Is this a known bug, or is there some new coding requirement when coding menu
handlers that I don't know about? I was hoping someone would confirm this on
another machine.

Fitzbew

---
A searchable archive of this list is available at:
<http://support.realsoftware.com/listarchives/search.php>

Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Re: Menu Handler firing twice in Classic
Date: 16.08.03 03:33 (Fri, 15 Aug 2003 22:33:37 -0400)
From: Jeff O'Brien
I am having the same problem under OS 9 but not under OS X
Let me know if you figure this out

Jeff

> I've just noticed that my custom menu-handlers fire twice in RB 5.2.1 in OS
> 9.X, both in compiled apps and in the debugger. No problem with the same code
> in RB 4.5.3, or in OS X or Win32.
>
> Autoenable is off.
>
> Can't find any evidence this is a known bug. Closest match I can find in the
> feedback database is jxmmjrul.
>
> Easy to reproduce in a new empty project.
>
> Is this a known bug, or is there some new coding requirement when coding menu
> handlers that I don't know about? I was hoping someone would confirm this on
> another machine.
>
> Fitzbew
>
> ---
> A searchable archive of this list is available at:
> <http://support.realsoftware.com/listarchives/search.php>
> Unsubscribe or switch delivery mode:
> <http://support.realsoftware.com/listmanager/>

---
A searchable archive of this list is available at:
<http://support.realsoftware.com/listarchives/search.php>

Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Re: Menu Handler firing twice in Classic
Date: 16.08.03 04:44 (Fri, 15 Aug 2003 20:44:31 -0700)
From: Terry Ford
At 10:33 PM -0400 8/15/03, Jeff O'Brien wrote:
>I am having the same problem under OS 9 but not under OS X
>Let me know if you figure this out

I'm in the process of developing a feedback report for double window
drawing in OS9 that doesn't happen in OSX. Stuck behind some home
jobs that have taken priority but this has been going on since 5.0 so
it can wait. Any example would be appreciated as I may be able to
help. Send off list.

Terry Ford

---
A searchable archive of this list is available at:
<http://support.realsoftware.com/listarchives/search.php>

Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Re: Menu Handler firing twice in Classic
Date: 16.08.03 02:45 (Sat, 16 Aug 2003 01:45:36 EDT)
From: Fitzbew aol.com

In a message dated 8/15/03 10:35:04 PM, <email address removed> writes:

> I am having the same problem under OS 9 but not under OS X
> Let me know if you figure this out
>
> Jeff
>
> > I've just noticed that my custom menu-handlers fire twice in RB 5.2.1 in
> OS
> > 9.X, both in compiled apps and in the debugger.  No problem with the same
> code
> > in RB 4.5.3, or in OS X or Win32.
> >
> > Autoenable is off.
> >
> > Can't find any evidence this is a known bug.  Closest match I can find in
> the
> > feedback database is jxmmjrul.
> >
> > Easy to reproduce in a new empty project.
> >
> > Is this a known bug, or is there some new coding requirement when coding
> menu
> > handlers that I don't know about?  I was hoping someone would confirm this
> on
> > another machine.
>

Well, I'm relieved that I'm not the only one this is happening to.

I'll file a bug report in the morning.

In the meantime, I will have to figure out a work around. Maybe a property
or something to "turn off" the menu handler on the second "loop".

Fitzbew

Re: Menu Handler firing twice in Classic
Date: 16.08.03 06:57 (Fri, 15 Aug 2003 22:57:10 -0700)
From: Terry Ford
At 1:45 AM -0400 8/16/03, <email address removed> wrote:
>In a message dated 8/15/03 10:35:04 PM, <email address removed> writes:
>
>>I am having the same problem under OS 9 but not under OS X
>>Let me know if you figure this out
>>
>>Jeff
>>

Please turn off HTML. It makes it un-readable.

Terry Ford