Xojo Conferences
XDCMay2019MiamiUSA

Problems building for Mac Classic (Real Studio network user group Mailinglist archive)

Back to the thread list
Previous thread: Student Developer Program?
Next thread: [ANN] XERD 1.0.1 Update


Using services   -   Jan Erik Moström <
  Problems building for Mac Classic   -   Peter Desjardins
   Re: Problems building for Mac Classic   -   Peter Desjardins
   Re: Problems building for Mac Classic   -   Joseph J. Strout
    Re: Problems building for Mac Classic   -   Peter Desjardins
   Re: Problems building for Mac Classic   -   Terry Ford
   Re: Problems building for Mac Classic   -   Terry Ford
   Re: Problems building for Mac Classic   -   Terry Ford

Problems building for Mac Classic
Date: 29.02.04 03:06 (Sat, 28 Feb 2004 21:06:22 -0500)
From: Peter Desjardins
RB 5.2.2 on WinXP

When I build for Mac OS Classic 8-9, I receive error type 1,010 and the
app crashes.
What does this error mean and what might be causing it? I have tried
increasing the memory requirements but this hasn't helped.

Thanks. This is urgent.

Peter

- - -
Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>

Re: Problems building for Mac Classic
Date: 29.02.04 03:11 (Sat, 28 Feb 2004 21:11:03 -0500)
From: Peter Desjardins
Clarification. The error type 1,010 appears when I run my app under OS 8.5.

> RB 5.2.2 on WinXP
>
> When I build for Mac OS Classic 8-9, I receive error type 1,010 and
> the app crashes.
> What does this error mean and what might be causing it? I have tried
> increasing the memory requirements but this hasn't helped.


- - -
Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>

Re: Problems building for Mac Classic
Date: 29.02.04 04:05 (Sat, 28 Feb 2004 21:05:45 -0600)
From: Joseph J. Strout
At 9:11 PM -0500 2/28/04, Peter Desjardins wrote:

>Clarification. The error type 1,010 appears when I run my app under OS 8.5.

MacOS launch error 1010 means that some needed library couldn't be
found. If you install MacsBug -- a low-level debugger utility which
every Mac developer (and most Mac users) should have installed at all
times prior to OS X -- then you'll get a more helpful message telling
you what the missing library is.

Do we still support 8.5? I was thinking our minimum nowadays was
8.6, but don't quote me on that, I could well be confused.

Best,
- Joe

Re: Problems building for Mac Classic
Date: 01.03.04 17:09 (Mon, 01 Mar 2004 11:09:57 -0500)
From: Peter Desjardins
Thanks Joseph and Terry.

It turns out that RB 5.2.1 works on Mac OS 8.1 up.
I think my problem was that I was building my Mac app on a WinXP machine
and had an ActiveX (WMP) loaded. That could explain the error type 1,010
I received on the Mac.

-Peter

> MacOS launch error 1010 means that some needed library couldn't be
> found. If you install MacsBug -- a low-level debugger utility which
> every Mac developer (and most Mac users) should have installed at all
> times prior to OS X -- then you'll get a more helpful message telling
> you what the missing library is.
>
> Do we still support 8.5? I was thinking our minimum nowadays was 8.6,
> but don't quote me on that, I could well be confused.


- - -
Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>

Re: Problems building for Mac Classic
Date: 29.02.04 11:04 (Sun, 29 Feb 2004 02:04:11 -0800)
From: Terry Ford

On 28-Feb-04, at 7:05 PM, Joseph J. Strout wrote:

> At 9:11 PM -0500 2/28/04, Peter Desjardins wrote:
>
>> Clarification. The error type 1,010 appears when I run my app under
>> OS 8.5.
>
> MacOS launch error 1010 means that some needed library couldn't be
> found. If you install MacsBug -- a low-level debugger utility which
> every Mac developer (and most Mac users) should have installed at all
> times prior to OS X -- then you'll get a more helpful message telling
> you what the missing library is.
>
> Do we still support 8.5? I was thinking our minimum nowadays was 8.6,
> but don't quote me on that, I could well be confused.

If RB requires CarbonLib 1.6 then OS 8.6 is the minimum that came
installed with it.

Since it's an extension, one could possibly download it from Apple and
try it in 8.5. No guarantees what it might do to the system though.

Just a thought.

Terry

- - -
Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>

Re: Problems building for Mac Classic
Date: 29.02.04 11:23 (Sun, 29 Feb 2004 02:23:52 -0800)
From: Terry Ford

On 29-Feb-04, at 2:04 AM, Terry Ford wrote:

>
> On 28-Feb-04, at 7:05 PM, Joseph J. Strout wrote:
>
>> At 9:11 PM -0500 2/28/04, Peter Desjardins wrote:
>>
>>> Clarification. The error type 1,010 appears when I run my app under
>>> OS 8.5.
>>
>> MacOS launch error 1010 means that some needed library couldn't be
>> found. If you install MacsBug -- a low-level debugger utility which
>> every Mac developer (and most Mac users) should have installed at all
>> times prior to OS X -- then you'll get a more helpful message telling
>> you what the missing library is.
>>
>> Do we still support 8.5? I was thinking our minimum nowadays was
>> 8.6, but don't quote me on that, I could well be confused.
>
> If RB requires CarbonLib 1.6 then OS 8.6 is the minimum that came
> installed with it.
>
> Since it's an extension, one could possibly download it from Apple and
> try it in 8.5. No guarantees what it might do to the system though.

One more thought;
Why not just upgrade to OS 8.6? You can download the upgrade (for free
I think) from Apple at:

<http://docs.info.apple.com/article.html?artnum0047>

Terry


- - -
Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>

Re: Problems building for Mac Classic
Date: 29.02.04 11:27 (Sun, 29 Feb 2004 02:27:12 -0800)
From: Terry Ford

On 29-Feb-04, at 2:23 AM, Terry Ford wrote:

> One more thought;
> Why not just upgrade to OS 8.6? You can download the upgrade (for free
> I think) from Apple at:
>
> <http://docs.info.apple.com/article.html?artnum0047>

Oops, wrong URL, That was for CarbonLib 1.6

Try;

<http://download.info.apple.com/Apple_Support_Area/
Apple_Software_Updates/English-North_American/Macintosh/System/
Mac_OS_8.6_Update/>

for OS 8.6.

Terry

- - -
Unsubscribe or switch delivery mode:
<http://support.realsoftware.com/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>