Xojo Conferences
XDCMay2019MiamiUSA

Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows (Real Studio network user group Mailinglist archive)

Back to the thread list
Previous thread: MenuHandler in Class always fires first (before App or Window)
Next thread: SOT: Premature Optimization


Win32 API Declares   -   Berg, Heath
  Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows   -   Chris Smolinski
    MBS Plugin - Quicktime Movie glitch/pause in playback under Windows   -   Chris Smolinski
     Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows   -   Christian Schmitz
     Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows   -   Matthias Buercher
   Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows   -   Chris Smolinski
    Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows   -   Christian Schmitz

Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows
Date: 01.08.06 16:00 (Tue, 1 Aug 2006 11:00:05 -0400)
From: Chris Smolinski
>From: Matthias Buercher
>
>does he have the same problem in quicktime player?

Yes, he just reported that he does, so it seems to be a problem
specific to QuickTime vs the MBS plugin or my implementation. He's
running QuickTime 6.5.1 on Windows. So now to poke around and see if
I can find anyone else reporting this problem with QuickTime and
Windows...

MBS Plugin - Quicktime Movie glitch/pause in playback under Windows
Date: 30.07.06 15:38 (Sun, 30 Jul 2006 10:38:00 -0400)
From: Chris Smolinski
One of my programs uses the Quicktime movie class in the MBS Plugin
to play mp3 audio files. I have a user who reports that on any mp3
file he plays, he gets a glitch/pause in the audio roughly between
2:30 minutes and 2:48 minutes into the playback. I've been unable to
duplicate it here (he's running XP home and I have XP Pro on my
windows test machine), nor do I have any other reports of it, so I am
not sure exactly what is happening.

Has anyone run into this before, or does anyone have any ideas what
might be causing it? I've had him try quitting any other programs
that might be running, that didn't help.

Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows
Date: 30.07.06 21:18 (Sun, 30 Jul 2006 22:18:06 +0200)
From: Christian Schmitz
Chris Smolinski <<email address removed>> wrote:

> Has anyone run into this before, or does anyone have any ideas what
> might be causing it?

Do you call QuickTimePollMBS often enough?

Normally your app may call it in a 50ms timer.

Gruß
Christian

-

Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows
Date: 30.07.06 21:18 (Sun, 30 Jul 2006 22:18:44 +0200)
From: Matthias Buercher
does he have the same problem in quicktime player?

On 30 juil. 06, at 16:38, Chris Smolinski wrote:

> One of my programs uses the Quicktime movie class in the MBS Plugin
> to play mp3 audio files. I have a user who reports that on any mp3
> file he plays, he gets a glitch/pause in the audio roughly between
> 2:30 minutes and 2:48 minutes into the playback. I've been unable
> to duplicate it here (he's running XP home and I have XP Pro on my
> windows test machine), nor do I have any other reports of it, so I
> am not sure exactly what is happening.

_______________________________________________
Unsubscribe or switch delivery mode:
<http://www.realsoftware.com/support/listmanager/>

Search the archives of this list here:
<http://support.realsoftware.com/listarchives/lists.html>

Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows
Date: 31.07.06 17:24 (Mon, 31 Jul 2006 12:24:40 -0400)
From: Chris Smolinski
>From: <email address removed> (Christian Schmitz)
>Date: Sun, 30 Jul 2006 22:18:06 +0200
>
>Chris Smolinski <<email address removed>> wrote:
>
>> Has anyone run into this before, or does anyone have any ideas what
>> might be causing it?
>
>Do you call QuickTimePollMBS often enough?
>
>Normally your app may call it in a 50ms timer.

I call it in a 100 msec timer. My application can possibly be be
playing multiple sounds, so I call it for each sound I am playing,
every 100 milliseconds. I also have a thread that runs every 100 msec
which calls it for any sounds playing, as I was having some issues
under OSX with glitchy playback, and that seemed to help.

What is curious is that he reports the glitch always happens between
2:30 and 2:48 into the sound file, I am sure that is significant, but
I'm not sure what it means! :-) I have not had other reports of
this, it doesn't happen when I try it here under Windows XP (Pro, he
is using XP Home).

I will try changing to 50 msec and send him a copy to try out, but
based on the symptoms (the glitch occurring after roughly 2 1/2
minutes), I am not very confident that will do it.

Re: MBS Plugin - Quicktime Movie glitch/pause in playback under Windows
Date: 31.07.06 18:11 (Mon, 31 Jul 2006 19:11:28 +0200)
From: Christian Schmitz
Chris Smolinski <<email address removed>> wrote:

> I also have a thread that runs every 100 msec which calls it for any
> sounds playing,

Better 50ms and just once, not for each sound file.

> What is curious is that he reports the glitch always happens between
> 2:30 and 2:48 into the sound file, I am sure that is significant, but
> I'm not sure what it means! :-)

Maybe at that point QuickTime is loading more data.

The problem is often also that Timers do not fire always.
So while you do a long computation the app is blocked for some time and
the sound buffers run emtpy.

Gruß
Christian

-