Xojo Developer Conference
25/27th April 2018 in Denver.
MBS Xojo Conference
6/7th September 2018 in Munich, Germany.

shown event (Real Studio network user group Mailinglist archive)

Back to the thread list
Previous thread: Re: problem with format
Next thread: Update MacOSLib AppleScript


TypeLibs and API Interfaces for Windows   -   Garth Hjelte
  shown event   -   Joseph Claeys
   Re: shown event   -   Joseph Claeys
   Re: shown event   -   Joseph Claeys

shown event
Date: 02.08.11 01:30 (Mon, 1 Aug 2011 19:30:45 -0500)
From: Joseph Claeys
Since I wanted to use some of the new features I started upgrading one of my r1.1 WE apps to r2.

None of my listbox's filled. In fact, nothing did. I thought it was a database issue but upon further inspection it appears that the shown event isn't firing.

Is this a bug or is this a new expected behavior that I'm not fully grasping?

- Joe
_______________________________________________
Unsubscribe or switch delivery mode:
<http://www.realsoftware.com/support/listmanager/>

Search the archives:
<http://support.realsoftware.com/listarchives/lists.html>

Re: shown event
Date: 02.08.11 05:41 (Mon, 1 Aug 2011 23:41:57 -0500)
From: Joseph Claeys
Evidently r2 does what it's supposed to do when you put dbase.close (dbase is an instance of the realsqldatabase). I tossed that in some code and it doesn't shut down the database in r1 whereas in r2 it does and I had other code trying to query the database which failed in r2.

In short, r2 fixes something that I expected to stay broke.

On Aug 1, 2011, at 9:16 PM, Joseph Claeys wrote:

> Scratch that... Something else is amiss. It isn't the shown after all.
>
> For some reason my stuff isn't populating like it once was. I just can't figure out why. It works fine in 1.1.
>
> - Joe
>
> On Aug 1, 2011, at 7:30 PM, Joseph Claeys wrote:
>
>> Since I wanted to use some of the new features I started upgrading one of my r1.1 WE apps to r2.
>>
>> None of my listbox's filled. In fact, nothing did. I thought it was a database issue but upon further inspection it appears that the shown event isn't firing.
>>
>> Is this a bug or is this a new expected behavior that I'm not fully grasping?
>>
>> - Joe
>> _______________________________________________
>> Unsubscribe or switch delivery mode:
>> <http://www.realsoftware.com/support/listmanager/>
>>
>> Search the archives:
>> <http://support.realsoftware.com/listarchives/lists.html>
> _______________________________________________
> Unsubscribe or switch delivery mode:
> <http://www.realsoftware.com/support/listmanager/>
> Search the archives:
> <http://support.realsoftware.com/listarchives/lists.html>

_______________________________________________
Unsubscribe or switch delivery mode:
<http://www.realsoftware.com/support/listmanager/>

Search the archives:
<http://support.realsoftware.com/listarchives/lists.html>

Re: shown event
Date: 02.08.11 03:16 (Mon, 1 Aug 2011 21:16:02 -0500)
From: Joseph Claeys
Scratch that... Something else is amiss. It isn't the shown after all.

For some reason my stuff isn't populating like it once was. I just can't figure out why. It works fine in 1.1.

- Joe

On Aug 1, 2011, at 7:30 PM, Joseph Claeys wrote:

> Since I wanted to use some of the new features I started upgrading one of my r1.1 WE apps to r2.
>
> None of my listbox's filled. In fact, nothing did. I thought it was a database issue but upon further inspection it appears that the shown event isn't firing.
>
> Is this a bug or is this a new expected behavior that I'm not fully grasping?
>
> - Joe
> _______________________________________________
> Unsubscribe or switch delivery mode:
> <http://www.realsoftware.com/support/listmanager/>
> Search the archives:
> <http://support.realsoftware.com/listarchives/lists.html>

_______________________________________________
Unsubscribe or switch delivery mode:
<http://www.realsoftware.com/support/listmanager/>

Search the archives:
<http://support.realsoftware.com/listarchives/lists.html>