Xojo Conferences
MBSSep2018MunichDE
XDCMay2019MiamiUSA

re: realbasic-nug Digest, Vol 113, Issue 12 (Real Studio network user group Mailinglist archive)

Back to the thread list
Next thread: Re: This mailing list


re: realbasic-nug Digest, Vol 113, Issue 12   -   emile.a.schwarz

re: realbasic-nug Digest, Vol 113, Issue 12
Date: 10.08.13 08:28 (Sat, 10 Aug 2013 09:28:57 +0200 (CEST))
From: emile.a.schwarz
Franklin,

you never boot from a different hard disk ?

BTW: I just realized that that boot hard disk with a fresh XOJO is not registered (yet)

Emile

> --------------- ------------------- ----------------- ----------------
> Date: Fri, 9 Aug 2013 11:46:51 -0700
From: Franklin Veaux
Subject: Re: XOJO. Dialog.InitialDirectory: strange behaviour
To: Realbasic NUG
Message-ID: <<email address removed>>
Content-Type: text/plain; charset=us-ascii

On Aug 9, 2013, at 12:39 AM, "emile.a.schwarz" wrote:

> OpenDlg.InitialDirectory = GetFolderItem("")
>
> and this works as intended.
>
> Earlier today, I booted on an external hard disk (10.8.4), run XOJO (2013r2, from that disk), load that project and never have the intended "Initial Directory". Weird.
> The project was in the other hard disk (internal HD from a MacBook Pro), so I had to search it manually.

There does seem to be some weird behavior with OpenDlg.InitialDirectory. I haven't seen this exact behavior, but I talked a bit ago about how sometimes doing something like

OpenDlg.InitialDirectory = GetFolderItem(whatever)

doesn't work reliably, but

dim f as folderitem
f = getfolderitem(whatever)
OpenDlg.InitialDirectory = f

does work. I've never been able to figure out a reason for it.

_______________________________________________
Unsubscribe by sending a message to:
<<email address removed>>

Search the archives:
<http://support.realsoftware.com/listarchives/lists.html>