Xojo Developer Conference
25/27th April 2018 in Denver.
MBS Xojo Conference
6/7th September 2018 in Munich, Germany.

[MBS] Bugs? (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] 3.1pr6
Next thread: [MBS] 3.1pr5


Re: [MBS] MIDI Destinations and External Devices   -   Ron Benditt
  [MBS] Bugs?   -   Christian Schmitz
   Re: [MBS] Bugs?   -   Mike D.
    Re: [MBS] Bugs?   -   Christian Schmitz
     Re: [MBS] Bugs?   -   Mike D.
      Re: [MBS] Bugs?   -   Christian Schmitz
       [MBS] Re: Gamma   -   Mike D.

[MBS] Bugs?
Date: 20.01.03 23:18 (Mon, 20 Jan 2003 23:18:16 +0100)
From: Christian Schmitz
Hi,

before I go and add new features, can you please all send in emails
about bugs you have found in 3.1pr4?

Mfg
Christian

Re: [MBS] Bugs?
Date: 20.01.03 23:31 (Mon, 20 Jan 2003 14:31:20 -0800)
From: Mike D.
I've only had the chance to test the gamma fade in 3.1pr4, and it
still gets stuck on my machine at 50%.

Re: [MBS] Bugs?
Date: 21.01.03 00:36 (Tue, 21 Jan 2003 00:36:00 +0100)
From: Christian Schmitz
> I've only had the chance to test the gamma fade in 3.1pr4, and it
> still gets stuck on my machine at 50%.

Windows XP?

Mfg
Christian

Re: [MBS] Bugs?
Date: 21.01.03 01:34 (Mon, 20 Jan 2003 16:34:11 -0800)
From: Mike D.
> > I've only had the chance to test the gamma fade in 3.1pr4, and it
>> still gets stuck on my machine at 50%.
>
>Windows XP?

Yes, using the "3.1 prerelease" plugin dated 1/17/03 (7628418 bytes),
under windows XP, brand new Dell 1.7GHz with a pretty standard
display card (running 32 bit color).

Re: [MBS] Bugs?
Date: 22.01.03 02:26 (Wed, 22 Jan 2003 02:26:32 +0100)
From: Christian Schmitz
> > > I've only had the chance to test the gamma fade in 3.1pr4, and it
> >> still gets stuck on my machine at 50%.
> >
> >Windows XP?
>
> Yes, using the "3.1 prerelease" plugin dated 1/17/03 (7628418 bytes),
> under windows XP, brand new Dell 1.7GHz with a pretty standard
> display card (running 32 bit color).

Try again 3.1pr6.

I added a .nativegamma property.

some lines:

dim m as memoryblock
dim display as DisplayMBS

display=GetDisplay(0)
mÐsplay.nativegamma // save current gamma
display.nativegamma=newmemoryblock(3072) // everything black
msgbox "wating..." // press return to continue.
display.nativegamma=m // reset

This should make any screen black till you press return.
If this doesn't Windows XP may have some calibration. Else I have a bug
in the plugin.

Mfg
Christian