Xojo Conferences
MBSSep2018MunichDE
XDCMay2019MiamiUSA

[MBS] Re: Gamma (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] OT: RB apps -> bundle
Next thread: [MBS] 3.1pr6


Re: [MBS] Bugs?   -   Christian Schmitz
  [MBS] Re: Gamma   -   Mike D.
   Re: [MBS] Re: Gamma   -   Christian Schmitz

[MBS] Re: Gamma
Date: 22.01.03 04:27 (Tue, 21 Jan 2003 19:27:39 -0800)
From: Mike D.
>Try again 3.1pr6.
>
>I added a .nativegamma property.
>
>some lines:
>
> dim m as memoryblock
> dim display as DisplayMBS
>
> display=GetDisplay(0)
> mÐsplay.nativegamma // save current gamma
> display.nativegamma=newmemoryblock(3072) // everything black
> msgbox "wating..." // press return to continue.
> display.nativegamma=m // reset
>
>This should make any screen black till you press return.
>If this doesn't Windows XP may have some calibration. Else I have a bug
>in the plugin.

Hmm. I Tried it, and nothing happens.

To make sure, I also tried first manually setting the gamma to 70%,
then running this code, and still nothing happens.
Display.nativegamma() doesn't appear to affect the gamma at all.

With 3.1pr6 the other gamma problem is still there (sticks at 50%)

-

Re: [MBS] Re: Gamma
Date: 22.01.03 17:08 (Wed, 22 Jan 2003 17:08:07 +0100)
From: Christian Schmitz
> Hmm. I Tried it, and nothing happens.
>
> To make sure, I also tried first manually setting the gamma to 70%,
> then running this code, and still nothing happens.
> Display.nativegamma() doesn't appear to affect the gamma at all.

Well, it works perfectly here on Windows 98.
Tomorrow I can check some more Windows machines.

Or can someone else from this list verify this?

Mfg
Christian