Xojo Conferences
XDCMay2019MiamiUSA

[MBS] "InterfaceLib-GetComponentResource" could not be found. (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] RB plugin converter and the windows plugin
Next thread: [MBS] Fwd: execute rb app from a webserver or commandline


[MBS] Fwd: execute rb app from a webserver or commandline   -   Matthias Buercher
  [MBS] "InterfaceLib-GetComponentResource" could not be found.   -   Mike D.
   Re: [MBS] "InterfaceLib-GetComponentResource" could not be found.   -   Christian Schmitz
    Re: [MBS] "InterfaceLib-GetComponentResource" could not be found.   -   Mike D.
     Re: [MBS] "InterfaceLib-GetComponentResource" could not be found.   -   Kim

[MBS] "InterfaceLib-GetComponentResource" could not be found.
Date: 21.04.03 17:31 (Mon, 21 Apr 2003 09:31:44 -0700)
From: Mike D.
A user of my software is having a strange crash that I can't figure
out. I've advised him to "boot with 9.2.2 extensions only" because I
am worried he is having an Extension conflict. Here is what he says:

>I have try to startup only 9.2.2 Extensions & Control panels. But
>when I intall, it can't too. And appear a Error message:
>
>The application "Installer" could not be opened because
>"InterfaceLib-GetComponentResource" could not be found.
>
>You may need to install a newer version of
>"InterfaceLib-GetComponentResource".

I certainly don't link GetComponentResource in any declares. Is this
used by MBS?

Re: [MBS] "InterfaceLib-GetComponentResource" could not be found.
Date: 21.04.03 17:43 (Mon, 21 Apr 2003 18:43:51 +0200)
From: Christian Schmitz
> I certainly don't link GetComponentResource in any declares. Is this
> used by MBS?

1.
GetComponentResource is not used by the MBS plugin.

2.
All my plugins are 100% weak linked on Mac. The documentation utility
checks this while checking if all plugin functions are inside the
documentation and declarations match.

3.
GetComponentResource is part of QuickTime 3.0 or newer.

Mfg
Christian

Re: [MBS] "InterfaceLib-GetComponentResource" could not be found.
Date: 21.04.03 18:08 (Mon, 21 Apr 2003 10:08:17 -0700)
From: Mike D.
> > I certainly don't link GetComponentResource in any declares. Is this
>> used by MBS?
>
>1.
>GetComponentResource is not used by the MBS plugin.
>
>2.
>All my plugins are 100% weak linked on Mac. The documentation utility
>checks this while checking if all plugin functions are inside the
>documentation and declarations match.
>
>3.
>GetComponentResource is part of QuickTime 3.0 or newer.

Hmm. Maybe he turned off ALL extenstions by mistake. I'll follow
up on this...

Re: [MBS] "InterfaceLib-GetComponentResource" could not be found.
Date: 22.04.03 10:03 (Tue, 22 Apr 2003 21:03:05 +1200)
From: Kim
on 22/4/03 5:08 AM, Mike D. at <email address removed> wrote:

>>> I certainly don't link GetComponentResource in any declares. Is this
>>> used by MBS?
>>
>> 1.
>> GetComponentResource is not used by the MBS plugin.
>>
>> 2.
>> All my plugins are 100% weak linked on Mac. The documentation utility
>> checks this while checking if all plugin functions are inside the
>> documentation and declarations match.
>>
>> 3.
>> GetComponentResource is part of QuickTime 3.0 or newer.
>
> Hmm. Maybe he turned off ALL extenstions by mistake. I'll follow
> up on this...
This sounds like he has booted off the OS Install CD which has a hugely cut
down system and that will help less.
He needs to go to the extensions manager control panel and under the popup
menu sets (I think I recall it being called sets) select 'Mac OS 9.x.x Base
' (.x.x system version) than restart. Re-installing quicktime when Mac OS
9.x.x Base is on might be a good idea as well (recommended install not
standard).
I hope this helps.
From Kim