Xojo Conferences
MBSSep2018MunichDE
XDCMay2019MiamiUSA

[MBS] Issue with LaunchServicesItemInfoMBS (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] QT preserve pitch items
Next thread: [MBS] Whatever happened to the EqualMBS FolderItem function?


Re: [MBS] MIDI Destinations and External Devices   -   Ron Benditt
  [MBS] Issue with LaunchServicesItemInfoMBS   -   Beatrix Willius
   Re: [MBS] Issue with LaunchServicesItemInfoMBS   -   Christian Schmitz

[MBS] Issue with LaunchServicesItemInfoMBS
Date: 07.01.06 15:47 (Sat, 7 Jan 2006 15:47:25 +0100)
From: Beatrix Willius
Playing around with LaunchServicesItemInfoMBS I notice for the code

dim theFolderitem as folderitem
dim theLaunch as LaunchServicesItemInfoMBS =
theFolderitem.LaunchServicesItemInfoMBS(&h01)
Extension = theLaunch.Extension

and Folderitem names the following:

Bild 1.png : Extension is png
das.ist ein test: no Extension found
das ist ein.test: Extension test found

In the third case the extension is incorrectly found. Can you correct
this?

Using Mac OS 10.4, RB 2005R4, MBS 5.5



Mit freundlichen Grüßen/Regards

Trixi Willius

http://www.mothsoftware.com
Mail Archiver X: archive, clean and search email
http://www.beatrixwillius.de
Fractals, 3d landscapes etc.

_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
http://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] Issue with LaunchServicesItemInfoMBS
Date: 07.01.06 23:32 (Sat, 7 Jan 2006 23:32:43 +0100)
From: Christian Schmitz
Beatrix Willius <<email address removed>> wrote:

> Playing around with LaunchServicesItemInfoMBS I notice for the code
>
> dim theFolderitem as folderitem
> dim theLaunch as LaunchServicesItemInfoMBS =
> theFolderitem.LaunchServicesItemInfoMBS(&h01)
> Extension = theLaunch.Extension
>
> and Folderitem names the following:
>
> Bild 1.png : Extension is png
> das.ist ein test: no Extension found
> das ist ein.test: Extension test found
>
> In the third case the extension is incorrectly found. Can you correct
> this?

This is not a bug for me as the result comes directly from the
LaunchServices Framework.

I bet .test is in the extension database or .test is always a valid
expected to be an extension as it has exact 4 letters.

Mfg
Christian