Xojo Conferences
MBSSep2018MunichDE
XDCMay2019MiamiUSA

[MBS] Mach-O crash with mbs version 6.0 but not version 5.4 (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] Very slow compile... :(
Next thread: [MBS] Rockey


Re: [MBS] MIDI Destinations and External Devices   -   Ron Benditt
  [MBS] Mach-O crash with mbs version 6.0 but not version 5.4   -   Lisa Sawin
   Re: [MBS] Mach-O crash with mbs version 6.0 but not version 5.4   -   Christian Schmitz

[MBS] Mach-O crash with mbs version 6.0 but not version 5.4
Date: 30.03.06 20:20 (Thu, 30 Mar 2006 14:20:19 -0500)
From: Lisa Sawin
Hi, I'm have just discovered that my apps do not run on Mac OS 10.2.8
if I build them as mach-o using the mbs plugins version 6.0. This was
not the case with mbs plugins version 5.4. Here's a crash report:

> Thread 0 Crashed:
> #0 0x8fe01280 in halt
> #1 0x8fe106b4 in link_in_need_modules
> #2 0x8fe1016c in bind_lazy_symbol_reference
> #3 0x8fe00ec0 in stub_binding_helper_interface
> #4 0x0109709c in Z16LoadMachOPluginsv
> #5 0x01097158 in LoadPlugins
> #6 0x01101da0 in RuntimeInitExternalClasses
> #7 0x002fccd4 in _Main
> #8 0x000015e4 in % main
> #9 0x003d2fe4 in _start
> #10 0x003d2eb4 in start
>

Any clues as to what is going on? Thanks!

Lisa



------------------------------------------
Lisa Sawin
Glass Bead Software
http://www.glassbead.com/

REALbasic 2005 r4 running on Mac OS 10.3.9

_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
http://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] Mach-O crash with mbs version 6.0 but not version 5.4
Date: 30.03.06 20:26 (Thu, 30 Mar 2006 21:26:37 +0200)
From: Christian Schmitz
Lisa Sawin <<email address removed>> wrote:

> Any clues as to what is going on? Thanks!

Well, maybe for one plugin the compiler settings are set bad.

I recompile the plugins here and you can check again with 6.1pr7 later
tonight. ok?

Mfg
Christian