Xojo Conferences
XDCMay2019MiamiUSA

[MBS] Weird serial number error (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] QTGraphicsImporterMBS.makePicture returns good picture with 0 depth?
Next thread: [MBS] KeyCodesMBS class


RE: [MBS] DOM classes for Mac OS X HTMLViewer   -   Giovanni
  [MBS] Weird serial number error   -   Jerry Fritschle
   Re: [MBS] Weird serial number error   -   Christian Schmitz
   Re: [MBS] Weird serial number error   -   Jerry Fritschle

[MBS] Weird serial number error
Date: 15.03.08 06:33 (Sat, 15 Mar 2008 00:33:05 -0500)
From: Jerry Fritschle
I have a customer in Australia who gets an "MBS plugin serial number
not valid" message box (I followed your example in setting this up)
when he attempts to launch his customized version of my application.
His machine is running 10.4.10. I am developing in the US on 10.5.2,
and to this point have been unable to reproduce this. Nor have I had
reports of this from any other customers.

I am using 8.1 plugins in 2008r1.

I do obfuscate the serial number in my code, having a function which
regenerates it from several string snippets. I tried making this
method a little simpler, but that did not help him. Actually, though,
he did not have any problems till I went to the 8X plugins with the
new serial number; the obfuscation method had not otherwise been
changed.

The plugin registration method is called in app.open, and is in a
module which is an external item common to all versions, for all
customers, of my project.

Again, the killer is that it seems to work for everyone else,
including me, so I'm baffled.
-----
"Drama is life with the dull bits cut out."
-Alfred Hitchcock

Jerry Fritschle
<email address removed>

_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
http://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] Weird serial number error
Date: 16.03.08 03:51 (Sat, 15 Mar 2008 21:51:11 -0500)
From: Christian Schmitz

Am 15.03.2008 um 00:33 schrieb Jerry Fritschle:

> I have a customer in Australia who gets an "MBS plugin serial number
> not valid" message box (I followed your example in setting this up)
> when he attempts to launch his customized version of my application.

That's strange. You are currently the only user reporting a problem
like that.

Normally this problems come by:
- mixing different plugin versions
- damaged RB caches
- having code using the plugins before doing the registration

Gruß
Christian

_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
http://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] Weird serial number error
Date: 16.03.08 16:55 (Sun, 16 Mar 2008 10:55:34 -0500)
From: Jerry Fritschle

On Mar 15, 2008, at 9:51 PM, Christian Schmitz wrote:

> You are currently the only user reporting a problem
> like that.

Figures :-)

> - mixing different plugin versions
> - damaged RB caches
> - having code using the plugins before doing the registration

In reverse order: Plugin registration is the first thing called in
App.Open, so should be OK there. Flushing out the caches is the next
thing I will try. Pretty sure that I haven't mixed versions, so
caches may be the best bet.

Still, it's weird it's only happening to one of my users.

-----
"Drama is life with the dull bits cut out."
-Alfred Hitchcock

Jerry Fritschle
<email address removed>

_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
http://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info