Xojo Conferences
XDCMay2019MiamiUSA

[MBS] movie.LoopingMBS (MBS Xojo Plugin Mailinglist archive)

Back to the thread list
Previous thread: [MBS] Facial Recognition
Next thread: [MBS] DarwinIFStatInterfaceMBS


Re: [MBS] [ANN] MonkeyBread Software releases tutorial videos   -   Christian Schmitz
  [MBS] movie.LoopingMBS   -   Jon Daggett
    Re: [MBS] movie.LoopingMBS   -   Joe Huber
    Re: [MBS] movie.LoopingMBS   -   Jon Daggett
     Re: [MBS] movie.LoopingMBS   -   Christian Schmitz
      Re: [MBS] movie.LoopingMBS   -   Jon Daggett
      Re: [MBS] movie.LoopingMBS   -   Jon Daggett
       Re: [MBS] movie.LoopingMBS   -   Christian Schmitz
        Re: [MBS] movie.LoopingMBS   -   Jon Daggett
        Re: [MBS] movie.LoopingMBS   -   Jon Daggett

[MBS] movie.LoopingMBS
Date: 07.01.09 04:00 (Tue, 6 Jan 2009 22:00:18 -0500)
From: Jon Daggett
Christian (or anyone else),

I am trying to use the:
movie.LoopingMBS as integer

with a Quicktime movie, but it doesn't seem to work.

I have tried both reading and writing the value. I assume this should
be the same as setting Loop or Palindrome mode in QuickTime Pro, but
doesn't appear to work.

Any ideas?

Thanks,

Jon Daggett
_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] movie.LoopingMBS
Date: 07.01.09 05:39 (Tue, 6 Jan 2009 20:39:41 -0800)
From: Joe Huber
At 10:00 PM -0500 1/6/09, Jon Daggett wrote:
>I am trying to use the:
>movie.LoopingMBS as integer
>
>with a Quicktime movie, but it doesn't seem to work.
>
>I have tried both reading and writing the value. I assume this should
>be the same as setting Loop or Palindrome mode in QuickTime Pro, but
>doesn't appear to work.

Since that is a method of the Movie class, maybe it just sets the
flag in the movie file you're editing. It may not affect the current
Movieplayer.

Have you tried using RB's native MoviePlayer.Looping method to get
looping in the player itself?

Regards,
Joe Huber
_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] movie.LoopingMBS
Date: 07.01.09 12:57 (Wed, 7 Jan 2009 06:57:43 -0500)
From: Jon Daggett
Hi Joe,

re: movie.LoopingMBS

> Since that is a method of the Movie class, maybe it just sets the
> flag in the movie file you're editing. It may not affect the current
> Movieplayer.
>
> Have you tried using RB's native MoviePlayer.Looping method to get
> looping in the player itself?

Yes, that works fine. I'm trying to actually set that attribute on
the movie file itself (not the MoviePlayer), which is what that method
should be doing. It would be like setting the Preferred Volume,
Preferred Rate, or anything else that is actually embedded in the
movie file itself. You can do this in Quicktime Pro, but I need to be
able to read/write that attribute from RB.

Thanks,

Jon
_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] movie.LoopingMBS
Date: 07.01.09 22:23 (Wed, 7 Jan 2009 22:23:39 +0100)
From: Christian Schmitz
Jon Daggett <<email address removed>> wrote:

> Hi Joe,
>
> Yes, that works fine. I'm trying to actually set that attribute on
> the movie file itself...

Do you commit the changes to the disc after you changed the movie?

Gruß
Christain

-

Re: [MBS] movie.LoopingMBS
Date: 07.01.09 22:42 (Wed, 7 Jan 2009 16:42:39 -0500)
From: Jon Daggett
> Do you commit the changes to the disc after you changed the movie?

Yes, I tried a mov.CommitChanges but didn't seem to make a difference.

I am successfully changing the PreferredVolume and PreferredRate and
they are saving into the movie, but the looping doesn't.

ALSO, I can change the looping mode in Quicktime Pro, and save it, but
then when reading that value from RB, all of the values show "0" for
any movie file (but "0" is supposedly looping, and even movies that
aren't set to loop show up that way).

I just don't think it's working properly at all. Do you have a test
project you've tried and you know works? If so, could you send me one
to try?

Thanks,

Jon
_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] movie.LoopingMBS
Date: 08.01.09 01:48 (Wed, 7 Jan 2009 19:48:26 -0500)
From: Jon Daggett
Christian,

> Do you commit the changes to the disc after you changed the movie?

Correction. It does seem to be writing the Looping property to the
movie (after doing .CommitChanges), but it is not Reading the value
properly.

Reading the mov.LoopingMBS value seems to always return 0, regardless
of the actual looping mode.

Ideas?

Jon
_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] movie.LoopingMBS
Date: 08.01.09 15:01 (Thu, 8 Jan 2009 15:01:31 +0100)
From: Christian Schmitz
Jon Daggett <<email address removed>> wrote:

> Reading the mov.LoopingMBS value seems to always return 0, regardless
> of the actual looping mode.

I think I fixed a bug there for 9.0pr3.
And I'll include the test project.

Greetings
Christian

Re: [MBS] movie.LoopingMBS
Date: 08.01.09 15:10 (Thu, 8 Jan 2009 09:10:02 -0500)
From: Jon Daggett
> I think I fixed a bug there for 9.0pr3.

Great. When will you have pr3 available? I can give it a try.

Thanks,

Jon
_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info

Re: [MBS] movie.LoopingMBS
Date: 12.01.09 15:11 (Mon, 12 Jan 2009 09:11:23 -0500)
From: Jon Daggett
Christian,

re: movie.LoopingMBS

> I think I fixed a bug there for 9.0pr3.

Yes, it works properly now. Thanks!

Jon

_______________________________________________
Mbsplugins_monkeybreadsoftware.info mailing list
<email address removed>
https://ml01.ispgateway.de/mailman/listinfo/mbsplugins_monkeybreadsoftware.info